Current Cost Support Forum

GaSmart problems
Page 1 of 1

Author:  rwg [ Mon May 13, 2013 8:56 am ]
Post subject:  GaSmart problems

Last week I bought a GaSmart transmitter (one of the RJ11 versions) to plug into my R5 style gas meter. Very quick delivery (thanks!).

Anyway, the actual transmitter seems to be working nicely - I've paired it with my EnviR for both the current usage and data channels and I can see the data output for those channels in the serial output from the EnviR if I watch that. However I don't get any actual usage when gas is used - in fact the only time anything changes at all is when I unplug and re-plug the cable into the gas meter, at which point the impulse count in the <imp> bit of the serial output goes up by 1.

My interpretation of the most likely cause of this (perhaps the only cause?) is that the reed switch inside the meter isn't working and is staying closed all the time, so I don't see any usage pulses but I get a single pulse by plugging in the cable. If that's the case, it seems likely that I'm stuffed - short of a replacement gas meter, which would need a different sensor type anyway :(

Just thought I'd post here to see if anyone had any other suggestions before I give up on this and try to sell a (very lightly) used GaSmart RJ11...



Author:  majones [ Mon May 13, 2013 7:30 pm ]
Post subject:  Re: GaSmart problems

If you look elsewhere on the forum, you'll see that Automan had to snip the outer wires in his lead to get his configuration to work.

Author:  Automan [ Tue May 14, 2013 9:45 am ]
Post subject:  Re: GaSmart problems

Indeed, see viewtopic.php?f=18&t=96433#p109161

However, you may wish to have a chat with CC about changing the wiring in the lead between the meter and the little white box.


Author:  rwg [ Wed May 15, 2013 8:08 pm ]
Post subject:  Re: GaSmart problems

Ah, interesting stuff - I will look into it :)



Author:  rwg [ Wed May 15, 2013 8:38 pm ]
Post subject:  Re: GaSmart problems

Sadly not the problem in my case....

just tried a similar trick by putting insulation tape over pins 1,2,5&6 of the RJ11 plug, but same result - a pulse when I plug in and that's it.

Just to do things properly I dug out an old RJ11 cable and the multimeter and checked the state of the socket on the gas meter - of the 6 spaces for pins in the RJ11 socket there are 4 connections in positions 2,3,4 and 5. As far as I can tell, 2 and 5 are always connected to each other, as are 3 and 4. This ties in with the probability that my reed switch has bitten the dust... :(

On the RJ11 plug from the GaSmart, the pins are as follows (sit the plug with the pins facing up, wire going away from you, count pin 1 on the left, 6 on the right

1: Not connected
2: +3V (yellow wire visible inside the plug going to this pin)
3: +3V (green wire)
4: 0V (red wire)
5: 0V (black wire)
6: Not connected

Connecting either of the 3V pins (2 and 3) to either of the 0V pins (4 and 5) seems to give a pulse for me. This would explain automan's issue - if his meter internally has 2 connected to 5 then you'll get just one pulse on plug in, even if it is happily switching 3/4 as the gas is used.

On the plus side, I have a cunning plan... :D

The only thing in the house that uses gas is the boiler - it has a burner light on the front. I've designed a circuit that should detect that light being on and will connect to the RJ11 plug and send pulses at a constant (but adjustable) rate while the light is on. It won't be perfect as the boiler can reduce its power under some conditions, but it's better than nothing. When the bits arrive and I've got it working, I'll post the circuit diagram here in case anyone is interested.

cheers once again!


Page 1 of 1 All times are UTC [ DST ]
Powered by phpBB® Forum Software © phpBB Group